GM B-Body Forum, 77-79 Caprice/Impala Forum

Join Now If Your A 1977- 1979 Caprice or Impala owner or other GM B-Body owner!!!
Like us on Facebook https://www.facebook.com/BBodyForum?ref=hl

Join the forum, it's quick and easy

GM B-Body Forum, 77-79 Caprice/Impala Forum

Join Now If Your A 1977- 1979 Caprice or Impala owner or other GM B-Body owner!!!
Like us on Facebook https://www.facebook.com/BBodyForum?ref=hl

GM B-Body Forum, 77-79 Caprice/Impala Forum

Would you like to react to this message? Create an account in a few clicks or log in to continue.
GM B-Body Forum, 77-79 Caprice/Impala Forum

A forum for the owners and enthusiasts of General Motors B-Bodies from 1977-1990, but dedicated to the owners of 1977-1979 Impalas and Caprices. Join up now!


4 posters

    Engine Break In Mishap

    HeavyChevy77
    HeavyChevy77
    Freshman Member (Tier 3)
    Freshman Member (Tier 3)
    10th Year Anniversary
    10 years of being a member on our forum!


    Posts : 243
    Join date : 2013-07-03
    Age : 31
    Location : San Diego, Ca

    Engine Break In Mishap Empty Engine Break In Mishap

    Post  HeavyChevy77 Mon Apr 17, 2017 11:59 pm

    Ok been working on my motor swap making everything pretty painting brackets/engine/ engine bay frame/exhaust manifold was gonna post all the pics when done
    Finally found tdc since balancer mark wasn't lining up
    Got her started sounded great warmed up to break in cam @ 2k or little more varying little bit through out.
    Well 10 mins later BOOM!! Steam everywhere. ..my read end cap blew off ..panic cleaned the engine and assessed damage engine still runs fine thank god. But wondering what went wrong I filled the block then radiator BUT forgot to take of cap when initially starting up so im thinking just air in the system..
    Buying new rad tomorrow with me luck
    HeavyChevy77
    HeavyChevy77
    Freshman Member (Tier 3)
    Freshman Member (Tier 3)
    10th Year Anniversary
    10 years of being a member on our forum!


    Posts : 243
    Join date : 2013-07-03
    Age : 31
    Location : San Diego, Ca

    Engine Break In Mishap Empty Re: Engine Break In Mishap

    Post  HeavyChevy77 Tue Apr 18, 2017 12:30 am

    Engine Break In Mishap 20170410
    Fierro51
    Fierro51
    Sophomore Member (Tier 4)
    Sophomore Member (Tier 4)
    5th Year Anniversary
    Celebrating 5 years of being our member!


    Posts : 279
    Join date : 2016-01-20
    Location : Cheyenne, Wy

    Engine Break In Mishap Empty Re: Engine Break In Mishap

    Post  Fierro51 Tue Apr 18, 2017 9:54 am

    HeavyChevy77 wrote:Engine Break In Mishap 20170410
    ouch
    Kit1078
    Kit1078
    Freshman Member (Tier 3)
    Freshman Member (Tier 3)
    5th Year Anniversary
    Celebrating 5 years of being our member!


    Posts : 106
    Join date : 2015-04-26
    Location : Northeast Ohio

    Engine Break In Mishap Empty Re: Engine Break In Mishap

    Post  Kit1078 Tue Apr 18, 2017 10:05 am

    Looks like a faulty radiator. Unless it overheated or something else that would cause too much pressure in the cooling system. I've had those aluminum/plastic radiators fail there before, but not at initial startup.
    HeavyChevy77
    HeavyChevy77
    Freshman Member (Tier 3)
    Freshman Member (Tier 3)
    10th Year Anniversary
    10 years of being a member on our forum!


    Posts : 243
    Join date : 2013-07-03
    Age : 31
    Location : San Diego, Ca

    Engine Break In Mishap Empty Re: Engine Break In Mishap

    Post  HeavyChevy77 Tue Apr 18, 2017 10:34 am

    No overheating but maybe it cause I didn't remove the rad cap to purge air in the system?? Or a bad rad all I do know is that it scared the shit outta me when it happened.
    Myloth
    Myloth
    Moderator
    Moderator
    Helpful and Responsive Member!
    Very active with responding and helping other members with questions and concerns.
    5th Year Anniversary
    Celebrating 5 years of being our member!


    Posts : 638
    Join date : 2014-06-09
    Location : At the base of the Mountain (NY) Adirondacks

    Engine Break In Mishap Empty Re: Engine Break In Mishap

    Post  Myloth Wed Apr 19, 2017 1:01 am

    As rule the last thing I would do is put on the radiator cap. Usually fill then run motor then check level while engine is

    running and fill again. You def could have had lots of air in there to cause that problem. Sometime you even

    have to burp them few times to get it out.
    Fierro51
    Fierro51
    Sophomore Member (Tier 4)
    Sophomore Member (Tier 4)
    5th Year Anniversary
    Celebrating 5 years of being our member!


    Posts : 279
    Join date : 2016-01-20
    Location : Cheyenne, Wy

    Engine Break In Mishap Empty Re: Engine Break In Mishap

    Post  Fierro51 Wed Apr 19, 2017 6:44 pm

    replace the cap for piece of mind as well.

    Sponsored content


    Engine Break In Mishap Empty Re: Engine Break In Mishap

    Post  Sponsored content


      Current date/time is Sun Jul 21, 2024 1:13 pm