GM B-Body Forum, 77-79 Caprice/Impala Forum

Join Now If Your A 1977- 1979 Caprice or Impala owner or other GM B-Body owner!!!
Like us on Facebook https://www.facebook.com/BBodyForum?ref=hl

Join the forum, it's quick and easy

GM B-Body Forum, 77-79 Caprice/Impala Forum

Join Now If Your A 1977- 1979 Caprice or Impala owner or other GM B-Body owner!!!
Like us on Facebook https://www.facebook.com/BBodyForum?ref=hl

GM B-Body Forum, 77-79 Caprice/Impala Forum

Would you like to react to this message? Create an account in a few clicks or log in to continue.
GM B-Body Forum, 77-79 Caprice/Impala Forum

A forum for the owners and enthusiasts of General Motors B-Bodies from 1977-1990, but dedicated to the owners of 1977-1979 Impalas and Caprices. Join up now!


2 posters

    ignition issues 78 impala

    avatar
    thotrodder
    Newbie (Tier 1)
    Newbie (Tier 1)
    5th Year Anniversary
    Celebrating 5 years of being our member!


    Posts : 3
    Join date : 2016-10-17

    ignition issues 78 impala Empty ignition issues 78 impala

    Post  thotrodder Mon Sep 30, 2019 6:56 pm

    My daughters boyfriend hooked up jumper cables wrong and tried to start the car. It burned 2 wires to the starter and the starter. I replaced starter, alternator and ignition switch. The car will start but it wont stay running. There is no power in the run position to anything but when i turn all the way to start it starts but stops as soon as i let go of the switch. I tested power and i have power to my ignition circuit when its in start position but not in the run position. Any help would be appreciated im at a dead end. I have a manual for it but it just gives you the basic ignition circuit and not a detail of the what holds the run position.
    GM B-Body Forum
    GM B-Body Forum
    Admin
    Admin
    Helpful and Responsive Member!
    Very active with responding and helping other members with questions and concerns.
    10th Year Anniversary
    10 years of being a member on our forum!


    Posts : 755
    Join date : 2013-01-14
    Age : 31
    Location : Flint/Detroit, MI - Charlotte, NC

    ignition issues 78 impala Empty Re: ignition issues 78 impala

    Post  GM B-Body Forum Mon Sep 30, 2019 9:51 pm

    Sounds to me the ignition switch itself was fried. However there are fusible links along the main harness. I had an issue a few years ago on my 79, got no power to anything. I completely rewired it and removed all the fusible link, and installed a 250 amp mega fuse right off the battery. I have the full wiring diagram for these cars, they're posted on here too.
    GM B-Body Forum
    GM B-Body Forum
    Admin
    Admin
    Helpful and Responsive Member!
    Very active with responding and helping other members with questions and concerns.
    10th Year Anniversary
    10 years of being a member on our forum!


    Posts : 755
    Join date : 2013-01-14
    Age : 31
    Location : Flint/Detroit, MI - Charlotte, NC

    ignition issues 78 impala Empty Re: ignition issues 78 impala

    Post  GM B-Body Forum Mon Sep 30, 2019 9:54 pm

    I think im misreading your post. You checked power right at the pink plug on the distributor? If so thats directly from the ignition switch, meaning the switch is bad if your only getting power in start position.
    avatar
    thotrodder
    Newbie (Tier 1)
    Newbie (Tier 1)
    5th Year Anniversary
    Celebrating 5 years of being our member!


    Posts : 3
    Join date : 2016-10-17

    ignition issues 78 impala Empty ignition switch

    Post  thotrodder Tue Oct 01, 2019 5:29 am

    I replaced the ignition switch already. Yes i only get power when the switch is in the start position.

    Sponsored content


    ignition issues 78 impala Empty Re: ignition issues 78 impala

    Post  Sponsored content


      Current date/time is Fri Jun 21, 2024 1:04 am